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The MS Dynamics GP Management Reporter programs are stand-alone programs that assist 

with building, generating, printing and storing Financial Reports.  

 

This manual may be used for all versions of Management Reporter from MR2012 thru RU15.     

Any version differences are noted.  Screen-shots are from version MR2012 
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Management Reports Programs 
 

Management Reporter (or MR) consists of two programs for the general user:  Report 

Designer and Report Viewer.  These are listed under Microsoft Dynamics in the programs. 

 

 

 

 

 

 

Report Designer  
• Build Reports 

• Change existing reports 

• Run / generate reports each 

month with new data 

• Add users & security 

 

 

 

 

 

Report Viewer  
• Opens the Report 

Library (reports 

already 

generated)  
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How to Run a MR Report 
• Open the Report Designer    

o If it asks for a log on (then they are on Legacy); use your GP logon and password 

• Find the desired report on the top left and click on it.  It should load into the main 

window: 

 

 

 

• Check the Period and change as needed  

 

• Change the company if needed on top middle 

 

• Press the Generate button on top menu middle 

/ right   

 

• Report Queue Status window will open  

 

• Report will launch in either Internet Explorer 

or the Report Viewer 
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Report in Internet Explorer: 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Report in 

Viewer:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This default setting is stored in 

User Options  (Tools > Options)  
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Basic Parts of a MR Report 
 

Report Definitions:  is where you will run your Financial Statements 

 

Each Report is made up of: 

• A row definition – the specific rows on the report.   

o For example: 

▪ A detailed P&L might have a row for each Revenue GL account 

▪ A summary P&L might just have one row for all Revenue accounts 

o Row definition is where you specify:  

▪ what GL accounts are on the report and how they are grouped 

▪ section headers and ---- lines 

▪ where to subtotal and total   

▪ text formatting for the rows (For example: totals in bold) 

• A column definition – the columns on the report 

o For example: 

▪ Description; Current month; YTD 

▪ Account; Description; Current month; budget; Variance; % 

o Column definition is where you specify: 

▪ What data you want in each column  

• Actual vs Budget  

• Current vs YTD 

• Formulas for Variance or Percentage columns 

▪ Column headers 

▪ Specific column formats (Percentage; shaded) 

▪ Advanced - Column restrictions (for example – different department for 

each column) 

• Optionally, a catalog could have a Reporting Tree definition.  A Reporting Tree allows 

you to either: 

o add a filter to a report on a segment (or range of segments) – for example, 

particular department 

OR 

o makes separate reports for each value of a specific segment (or range of 

segments) – a report for EACH department, for example 
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Report Definition 
 

After selecting a specific Report under the Report Definitions, the Report properties window 

is displayed.  Here you can: 

• Change the report name and detail level 

• Change the Building blocks 

• Change the Output (Library location) 

• Change the Page Setup and Headers/Footers 

• Set other Report Options such as rounding, general number formatting, etc. 

• Generate the Report    

 

 

 

Missing Accounts 
 

In MR, you will find 

the Missing Account 

Analysis under Tools: 

  

  



MS Dynamics GP Management Reporter 
 

 

GP Management Reporter V2012.2   Page 7 of 22 

Building Block – Column Definitions 
 

Click on Column Definitions on the bottom left to display the 

existing Columns on the upper left of the navigation pane. 

 

You can press New button on the top left toolbar 

or 

Change/view an existing Column Definition by clicking on the list on 

the top left. 

 

 

Press the File – Save (or Save As) to save your work, make sure you 

use a generic description for your column layout: 
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Column Detail – Required Fields by Type 
 

• DESC –  Row Description from Row Format – No additional fields are needed 

 

• ACCT – GL Account Codes from Row Format – No additional fields are needed 

 

• FD – Amounts from General Ledger / Financial Dimension  

o Book Code: 

▪ ACTUAL – activity or balances from GP 

OR 

▪ Select a specific Budget ID from GP (use dropdown in field) 

o Fiscal Year and Period Code: 

▪ BASE is the period /year the report is run for at time of generation 

▪ BASE-1 is the prior period (or year) 

▪ Can also put in specific period numbers (eg: 4 for April) or a range (1 

to 3) 

o Periods Covered  

▪ PERIODIC – Current Period Activity 

▪ YTD – Year to Date Amounts 

▪ PERIODIC /BB – Beginning of Period Balance 

▪ YTD/BB – Beginning of Year Balance 

• CALC –  Calculated Column 

o Calc Formula –  enter a formula using the Column Letters 

▪ Add, Subtract 

• A+B or A-B+C 

• A TO D 

▪ Multiple, Divide 

• B*D or A/D 

• Also by a specific cell using the column letter and the row 

number from the row layout:  B/B100.  Note – it may be better 

to use the “Base Row” function so that this column layout can 

be used with other row formats.  See row format for details.   

C/BASE  

• Don’t forget to use the Special Format Mask on percentage 

columns (Use field dropdown to select) 

▪ Complex Calculations 

• Average ((A+B)/2)  

• etc.    

▪ If statements: 

• IF B>100 THEN B ELSE C*1.25 

 

Column Detail – Other common fields: 

• Column Width – Each type of field has default width but if you desire to tighten up or 

spread a report you may specify Column Widths for one or more columns 

• Extra Spaces Before Column 

• Special Format Mask – percentages, $, () for negative, etc.  
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Column Headers 
 

Click on the field and the …Insert AutoText button: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Also notice the Spread from, Spread to options to have a header over several columns. 
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Column Detail – Advanced Options 
• Print Control 

Non-printing column 

 

Variance columns – try the 

XCR (negative is always 

BAD then) 

 

Conditional – to make a 

report that has Actual if 

period is <=base, budget if 

> base   

 

 

 

 

 

• Reporting Unit – specific reporting unit on a Tree you will use when running this 

report – often used with multi-company report 

 

• Dimension Filters or Attribute Filters -- For columns whose TYPE is FD, the 

Dimension Filters or Attribute Filters cells can restrict a column to specific general 

ledger accounts.  

 

• Restricting Columns to Specific Dates – The Start Date and End Date cells restrict 

data in GL columns to specific dates.  This technique is useful for daily or weekly 

sales reporting, cash analysis needs, and other date-sensitive reports.  You can type a 

date using the day of the month or a full date.  

 

• Justification – for Description Column (Left, Center or Right)  
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Building Block - Row Definitions 
 

Click on Row Definitions on the bottom left to display the existing Row on the upper left of 

the navigation pane. 

 

You can press New button on the top left toolbar 

or 

Change/view an existing Row Definition by click on the list on the top left. 

 

 

Format Code (C): 

• Blank – GL account rows 

o Specify account(s) in J 

o On Liabilities and Revenue accounts specify “C” on Norm Bal (F) to reverse 

the sign and show as positive (instead of negative)  

• DES – Description or blank line 

o Specify description in B 

• ---  or  ===  underscore or double-underscore line 

• TOT – Total 

o Specify range or formula in D using the row codes (numbers) 

▪ 50:138 

▪ +145 +880 

• CAL – more complex calculation 

o Specify calculation in D 

• CBR – Change Base Row for % Alloc    

o Specify row code (number) in D 

o This should be first row on layout, can be repeated if you want another section 

to use a different row for calculations.  Use “BASE” in calculation on column 

layout 
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To add rows from the GP Chart of Accounts: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

It will insert any values 

for  

Segments with &&&. 

(### will be ignored) 

 

The Description will 

come from the Segment 

Description in GP (MS 

Dynamics > Setup > 

Financial > Segment) 

 

 

 

 

 

Fonts – upper left. 

There are some pre-defined font styles in MR.  You can also add your own. Format > Styles 

& Formatting 

 

Navigation: 

• Edit > Delete Row, Edit > Insert Row 

• Right mouse click for menus 

OR 

• Ctrl-C  to copy, Ctrl-V  to paste 

 

Edit > Renumber Rows - if you run out of row numbers, will change total references  
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Link to Financial Dimensions is where you specify the accounts you want to be included in 

the amount on that row.   Press the … to open the wizard window: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You can also add accounts (using the correct format) on the top formula bar (like in excel): 

 

 

 

Remember that you should only specify the segments required to define your accounts and 

should NOT specify segments to be used on the Tree or Column reporting units.   

 

Category or AA dimensions will be listed in addition to any GL account segments.  
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Report Options 
 

 

  

Detail Level: (for drilldown) 

• Financial – just the financial statement  

• Financial & Account – Financial statement and full accounts for each line 

• Financial, Account & Transactions – above plus additional detail to each GL 

transaction (Only if there is a current column – so not on Balance Sheets) 

 

Report Date - Default base period:  
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Settings: 

 

 

Report Page Settings 
• Click the ‘Other’ button on the Settings tab to open the Report Settings screen 

• The other settings allow you to control common page settings such as the size of the 

page, changing report orientation, and page order 
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Headers & Footers: 
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Building Block – Reporting Tree 

 

 

 

Edit > Insert Reporting Units from Dimensions  
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Administration 

How to add a user to MR 
Open the Report Designer as a user that currently has Administrative privileges in MR. 

  

Legacy will make a user sign into MR with their GP user for each company in MR. 

  

The Windows user who installed MR on the Process Server will be an Administrator by 

default, but some people will change this if they have a limited number of Administrators in 

MR. 

  

In the lower left corner of Report 

Designer, click on Security. 

You can see who currently has 

access, and their Effective Role 
 
  
To Add a user, right click anywhere 
in the white space, or click new in 
the upper left 
Users are added through Active 
Directory, not as SQL users. 
Click the Search button in the upper 
right 

Find your user in the list by entering part of 
their name and clicking Check Names.  
The user's name should resolve 

 
 Click OK to configure 
New users are always given the least amount of security, Viewer. You can change from there. 
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Remember! Any user who is NOT an 
Administrator will need to be given 
Company Access on that tab. 
  
 
  
You will need to check Permissions in the 
Report Viewer as well.  
Open the Report Viewer 
Click on Permissions 
Click Add to add the user you just added to 
MR in Report Designer 
In my example, I added Everyone already, 
which covers all new and existing users. In 
this case, nothing would need to be done 
here.  
 
  
  
If you add a User, that 
user will need to have 
permissions set at a 
folder level and what you 
want them to be able to 
do, for example here, this 
user would not be able to 
delete reports. 
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Adding or Removing Companies from MR (GP2015 or later) 

 
• Log into GP into company you wish to add/remove from MR as the ‘sa’ user – it must be 

‘sa’, you can’t do this as any other user. 

• Open Company Setup:  Administration (Or MS Dynamics GP > Tools > Setup) > 

Company > Company  

• Click Options Button 

• At the bottom of the Options page there’s an MR section, check the box to Enable General 

Ledger Reporting 

• Wait about 15 minutes for MR to populate.  

• Note – you may need to rebuild the Datamart after making these changes, especially if 

you removed a company. 
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Tips for Common Financial Statements 
 

Net Income on Balance Sheet 
 
For some chart of accounts the profit and loss accounts might not be in a contiguous range.  This is 
especially true if using account categories to define your financial dimension in the row definition. 
 
Use this shortcut to retrieve the net income on your balance sheet in the MR row definition: 
 

• Enter the following formula into the ‘Link to Financial Dimensions’ column to select all 
accounts (* is a wildcard) 

o  +Main = [*]  

• Enter the following formula into the ‘Row Modifier’ column to restrict to only profit and loss 
accounts 

o +Attribute=Account Type=[Profit and Loss] 
 
 
 

 
 
 

Cash Flow Statement Beginning Cash Balance 
 
Displaying the beginning cash balance on a cash flow statement with MTD and YTD values requires a 
couple of steps in report designer. 
 
In the row definition, create two rows for the beginning cash balance.  The first will be non-printing 

• In the non-printing row enter: 
o Financial Dimension to link to cash 
o Account Modifier = [/BB] in the Row Modifier  
o NP in the Print Control 

• In the second row enter: 
o CAL in the Format Code 
o Related rows should correspond to the columns in your column definition to pull the 

beginning balance from (Example: B=B.130, D=C.130) 
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• In the column definition, the period beginning balance column should correspond with the 
first column letter used in the formula previously covered in the row definition. 

• A column for YTD beginning balance is required.  Enter YTD/BB in the Periods Covered (See 
column C below) 

• A column for YTD is required (See column D below) 

• A column to calculate the YTD cash flow needs to subtract the YTD Beginning Balance column 
from the YTD column (See column E) 

 
 

• On the Report Definition, the calculation priority must be set to columns and then rows 
(Report Definition > Settings > Calculation Priority) 
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